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Welcome to Bonita Open Solution!

Download Bonita Open Solution 5.2: www.bonitasoft.com/products/downloads.php

Use this QuickStart Guide to get started with Bonita Open Solution and become familiar with
designing a process with its graphic tools.

Download, install, and launch Bonita Open Solution 5.2

Download Bonita All-in-One. When the zipped folder has been downloaded, extract all files. To
launch Bonita Open Solution and begin designing a process:

e open the unzipped bonita-all-in-one folder
e launch the BonitaStudio application file for your operating system.

QuicksStart Overview and Tutorial
The Overview may help you to begin working with Bonita Open Solution quickly. After the
Overview is a Tutorial that will take you through creating, running, and managing a Process step by

step.

QuickStart Overview

Import .bar files (created in BOS v5) ' Open some examples

Figure 1. Welcome to Bonita Studio

You can also go directly to User Experience (i] on the Tool Bar) where existing Processes and
Cases are managed.
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Bonita Studio

When you click New to enter Bonita Studio, the Whiteboard is ready to begin:

( J2 o N°
Qi b 4 Click Run to deploy a completed Process
5 Click User Experience to start and manage Process Cases

@ tse 2 Begin with a Start and the first Step ]

Click the Step to use the Context Palette ]

Or use the Palette to activate the Tools — click the element, drag to the Whiteboard ]

oo ety
= =Pl
| General Pame stepl (sbept)
Advaned
D Duergeicn f \
See the Overview of the s 3 Define Details for the selected element, including:
whole Process in ZoomOut o e Name

e Step Type (Human, Automatic, Subprocess)
Lanes can define parallel sequences in a Process * Process (global) and Step (local) Data variables

A Pool is a Process and can contain one or more e Step Actors (Group, Individual)
Lanes e Connectors (to external systems)

k e Transition Conditions (if-then) /

Figure 2. Bonita Studio ready to design a new Process
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Bonita User Experience:

s Sontrer

anbo ()
Gramed &
My cases 1)
[r—)
W Fosiow Up

[ e
¥ moee
ATreve
A i
it et
A St 3 cie
Buy a MM

‘Wb Furchass
# Dashboard
4 aamn

Bonita User EXDEF'EHCE .
User (admin)
sl aed) (Y[ Y N AT B identified
Salect Al Read ewead Starmed Unstamed Mone & wog
sso [N Menquest For Advanco Paymond - 83 (1) % & = Appenve Raquet wIn 23 P 0
o [EEEIE] Wob Purchass - 87 (1) = & = Sales Roview W 230 Pw 0 G QuickStart Cuide
e By @ MING - 82 (1} “ & = Model choics Wi 2:80 PM 0 G User Cuide
e Bary @ MINS - £1 {8} = & = Rocap VW10 2:29 PM U Tutorish
[ Request For Advance Payment - 82 (1) * & = Approve Request W10 2:23 PM (D
o IR Rocuess For Avasca Paymess - 31 (2 ® & = SuMciest Fuas 180 222 P
v RN web Purchase - B8 (1) * R Sales Rurvew WI0 207 M 0
S .3 = SRR

>

>

il [ Start Case starts New cases of each Process ]

Select I Himad Urnimad Starred Unstarmed Nooe

B Processes and cases can be managed in an email-like interface with
e Stars
e labels
e Read and unread options

Figure 3. Bonita User Experience provides an in-box to manage Processes and Cases
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QuicksStart Tutorial
Follow the QuickStart tutorial example to:

e Design a complete Process graphically in Bonita Studio, as you
0 Draw Steps and Transitions using the graphic tools in the Bonita Studio Palette
0 Create an iteration and add a Gate
0 Add Conditions to Transitions
0 Add Details to the Process (global variables)and to Individual Steps (local variables)
e Run the Process you create
e Complete a Process Case and interact with the manual Steps
e See the Process, and the Cases you will create, in Bonita User Experience
e Return to the Process and design Forms using the Form Builder function of Bonita Studio

Prepare to Design a Process Graphically in Bonita Studio
Design a simple process, Web Purchase:

1. A customer orders an item from a web store.

2. A company sales employee processes the request manually (approves it, rejects it, or adds
more information to the order).

3. If/when the customer’s order is approved, he/she pays for the order.

The customer chooses whether to have the item shipped by Express Delivery.

5. The transaction is archived.

E

The Process will look like this when completed:

: -"w.' . % es Revi if approved 8 P if yes
- ales Review - ay ™ Express Delivery
=
hd

| |
Y

if no

.
REi ECt ] .O

Figure 4. Completed Web Purchase Process

B | USRL if not approved

More Info

I‘
¥

(It might be helpful to keep this handy as you design the Process.)
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Launch Bonita Studio

Launch Bonita Studio and Select New to create a new Process. Bonita Studio will appear with a Start
a first Step.

Draw Steps and Transitions
Start by defining the Steps to create a Web Purchase process.
The first step in this Process is to review and process a customer’s order. (In this tutorial, you’ll

define the customer order after defining the process to handle it.)

Click the initial Step, if necessary, to highlight it. Note that its Context Palette is highlighted too.

T

Stepl

P

Figure 5. Begin a new Process with a Start and a Step

Go to the Details panel, click General if necessary to highlight it, and enter:

/' Details
2 sales Review
General Mame Sales Review { Sales_Review )
Advanced
Data | Sales employee receives order for processing
e | Description / \
Connectors Enter
Deadlines | 4 tivity type ﬁuman = Name' ' Sales Review
Forms g Description Sales employee
| Priority Mormal receives order for
processing
Activity Type Human

k Priority Normal /

Figure 6. Enter General Details for Sales Review
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Before adding the next Steps, define who will take action in this Step - the Actor(s).

Click the Actors in Details for Sales Review. Note that Initiator show up here as a default Actor.
However, since the Actor for this Step is not the Initiator, you will change this.

J Details

2 Sales Review

General ) Individual

Advanced | Initiator

Dita Choose... |

Actors Ed
Groups

Connectors Create...

Deadlines. | Remove

Forms

Select

. . Group and Create
Figure 7. Create a Group of Actors for Sales Review  \_

Complete the wizards:

s =NACN X

Select a connector for this group

Groups are used to create lists of users

type filter text

a (5 Bonita
(5 ProcessInitiator -- Person who takes the first action and starts the process
O Execute a RoleMapper -- Execute a Nova Bonita RoleMapper
{5 User List -- Enter individuals manually
(5 User Role -- Find users assigned to a given role
- [§]) LDAP
- -,'_"' Talend

Bonita and User List

[ Select

< Back Next > Bl
[

Figure 8. Select the option to manually enter names for a User List
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{5 User List =N X

Set the name of this group

A group identifies a list of individuals who can carry cut this task

Mame * Bales Employees
[ Sales_Employees )

Employees authorized to handle web sales
Description

Enter
Name Sales Employees

Description Employees
authorized to
handle web sales

Figure 9. Name the Group

When you define Actors in this Process, you'll include “admin” in the list. When you Run the
completed process, Bonita User Experience opens for the “Admininstrator” by default. Including the
admininstrator in the list of Actors for all Human Steps ensures that you'll see those Steps in the
default User Experience inbox.

(5 User List O | B

Enter individuals manually

Enter individuals' names, separated by a comma

Mames or variable * | admin, john, james, jack -

Save connector configuration...

Enter
Users admin, john, james, jack

Next > Finish | [ Cancel

Figure 10. Define the Actors in this Group
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The Group you just created will now show in the list of Groups available for this Step.

_/ Details

2 Sales Review

Genoe] | @ Group ) Individual

Advanced Initiator

Data Sales Employees @'

Actors Edit
Groups

Connectors Create...

Deadlines Remove

Forms

Figure 11. The newly created Group shows up in the Groups list for the Sales Review Step

Highlight Initiator and Remove this Actor.

_/ Details

2 Sales Review

General @ Group (0 Individual

Advanced

o Sales Employees m
Hechnes Edit...
Connectors | Grops |m
Deadlines E—
Forms

Figure 12. Sales Employees is now the only group of Actors for this Step

You’ll come back to this Step later to add additional Details.
At this point in the process, the sales employee can choose to:
1) validate the request and the customer can pay; OR

2) reject the request; OR

3) enter more information relevant to the customer’s order.

Accordingly, next add 3 Steps, all connected to Sales Review, as detailed below.
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Sales Review should still be highlighted. (If not, click it.) The Context Palette to the right of the Step
is highlighted too.

ey
O ]

[ Click on the Step tool (circled) and drag a new Step onto the Whiteboard ]

Figure 13. Use the Context Palette to draw new elements on the Whiteboard

Be sure that the new Step is highlighted. Go to Details and click General to name it:

Palette : [
- 2, [IK°®
Oend : i
() Bvemt
= Transitic %
%= Lane
IPosl
[ Tet Annctation
2]
@
,QM& Details
i - B Pay |
po e T T Grneral MName Pay { Pay )
h Advanced
Dsta Customer completes creadd caed pryment feem
Artnex Description
Connectors.
Deadines | 4 vrity type [Human - Enter
Piicaity | Mormal = Name Pay
Description Customer completes
credit card payment form

Activity type Human
Priority Normal

Figure 14. Name a new Step and enter its General Details
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Click on Actors to define:
_/ Details
2 Pay

“General | @ Group () Individual
Advanced .
Data

Actors

= Groups
Connectors

Deadlines

Remove

Forms

Select
Group and Choose
Figure 15. Define the Actors for this Step

G

Assign actors

Select one or more groups of actors who can carry cut this task,

type filker text

Initiator
Sales Employees

[ Select Initiator ]

| Finish || cConcel |

Figure 16. Select the Process Initiator as the Actor for this Step
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Now add the other 2 Steps connected to Sales Review. First, Reject. In Details -> General:

E R
¥ et

| 4 % Palette
|1k i
ep
(DEnd
() Evern 5
© Gate o( B e reven C @
= Transiton ‘é = b
:
I Psol ¥
[ Test Annctation 154
e (=]
@
iovon, 5[ oume i
= Reject
\o—) General  Name Raject { Reect )
f _— =T Advanced
Deta Request is rejected]
Connectars | DesTwtion
Dradlines,
activity type | Automatic = |
Enter
Name Reject

Description Request is rejected
Activity type Automatic

Figure 17. Add Reject Step and define its General Details

Then, More Info. In Details -> General:

L Overgen. % |7 v &l
e B Mare Info
|o—E=) ? General Hame MoreInfo [ f \
=] = e Sales employee enters ademionsl infoemstion Enter in General

Reial Description

R Name More Info

e~ (] Description Sales employee

[P i) enters
additional
information
Activity type Human

KPriority Normal /

Figure 18. Add More Info Step and define its General Details

Then in Details -> Actors -> Group, select Choose:
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_/ Details
2 More Info
el | @ Group ) Individual

. A&van ced
Data

Actors

i Groups

Connectors Create...
Deadlines | Remove

Forms

Figure 19. Choose the Group of Actors for More Info

Complete the Assign Actors wizard:

-

b =lE] = )

Assign actors

Select one or more groups of actors who can carry out this task.

type filter text

Initiator

Sales Employees

1 Select Sales Employees
Click Finish

| Finish || Cancel ]‘

Figure 20. Select the already defined Group Sales Employees

You’ll add the information that determines the necessary conditions (if-then) for each of these 3
Transition paths later.
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Rename the Pool from My Process toWeb Purchase. Click on the Pool to deselect all
elements. Click on MyProcess -> Details -> Pool:

3 * MyProcessDiageam (L) X
¥ et

L4 i Palette
|1k ]
Step
Stan
() Evern
b Gate ) of B i ®.
= Teansiteon 1
- Lane
[ Test Annctation Mok m
=]
®
& Overen agm 3
] ] Web Purchase
= = )
J. b] Pool Hame Web Purchase { Web_Purchase )
B = — (5
Connestor Simple el ite
Dependenciss. | fescroticn
Feems.
i Enter
Name Web Purchase
Version 1.4
Description Simple item purchase

from Web site —
tutorial example

Figure 21. Rename this Pool

Rename the Process Diagram from MyProcessDiagram to Web Purchase Diagram. Click
outside the Pool to deselect all elements. Click on MyProcessDiagram -> Details -> Diagram:

S ovovion, il — i
=] < 1 Web Purchase Diagram
1 ). b] Diagram Hame Web Purchase Diagram | Web_Purchase_Disgram )
B = e I
Simple Aem purchase frem Web site-
peariten Enter
Name Web Purchase Diagram
Version 1.4

Description Simple item purchase
from Web site —
tutorial example

Figure 22. Rename this Process Diagram
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eboard tab is now labeled Web Purchase Diagram (1.0) and

the Pool is now labeled Web_Purchase. Continue the Process definition.

As the customer completes the Pay Step, he/she will choose whether the item is to be sent express.
Click Pay and use the Context Palette to add a new Step. Name it Express Delivery.

B MyProcesDiagram 00) X |

1 %F Palette r
i

Step ¢
O\uu .Q Py *  Espress Debeerry O

End
(0) Evert i ) %‘ =

© Gate 5 ( . F

iLene {
[ Tent Anncuation

=]
®
[ | Express Delivery
jo—2) — [Geverdl  raume Express Delvery { Eapress Delivery |
= 1= ;tm“ Send iteen via 3-clay delivery
G i Description
Deacllines
Actvity type. [Asomeie =] Enter
Name Express Delivery
Description Send item via 3-
day delivery

Figure 23.
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Activity type: Automatic

Add Express Delivery Step and define its General Details
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End this Process by archiving the interaction. Add a Step after Express Delivery, go to Details ->
General, and name it Archive.

i, Overew % | v 5
P pp— | Archive |
I (—] !
|o—E=) = General Name Aschive { Bachive )
=3 l:-:n:rﬂ System sechives record of transactien
Conmectans. Description
Destines Enter
' gedd™ Name Archive
Description  System archives
record of
transaction

Activity type Automatic

Figure 24. Add Archive Step and define its General Details

Now that all the Steps have been defined, add the Transitions to connect them.

As “no-express-delivery” requests will also be archived, add a Transition between Pay and Archive.
Select - Transition from the Palette, click Pay and drag the arrow to Archive.

As rejected requests will also be archived, add a Transition between Reject and Archive. Select >
Transition, then Reject and drag to Archive.

End the process — highlight Archive and add an End. Drag the Event into place, and select the red
End event to create and End.

ﬁ@g End
ee

Figure 25. Add an End event
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Click and drag the individual elements in your Process to rearrange them if you wish. Unruly
transition arrows can be moved manually by selecting the Transition, and clicking or unclicking the
Automatic layout box in its Details.

(L. - BSaIes Review - Pay *|  Express Delivery

o

Web Purchase

! .
> b bo
:

Figure 26. Rearrange the Process elements on the Whiteboard

Mare Info

I'

The general sequence of the Process is nearly defined. Now add missing information to complete it.

Create an Iteration and add an XOR gate

Note that More Info has an input but no output. In this simple tutorial example Process, the output
will be returned to the sales employee so he/she can add information and complete the approval.

However, Sales Review will then have two inputs. A Gate will define how these inputs should be
treated. Sales Review can proceed with either input, so an XOR Gate is needed.

.
' —* O = ‘ggales Review B
N = Pay
H —
T
| P +

T
B' More Info
KSeIect Gate from Palette and place it on the Whiteboard. \

e Change Gate Type to XOR.

e Draw Transition between More Info and Gate.
(Select = from the Palette, click More Info and drag the
arrow to Gate.)

e Delete Transition Start - Sales Review (with a right click or
with Delete on the keyboard)

e Draw new Transition Start - Gate.

KDraw new Transition Gate - Sales Review. j

Figure 27. Add an XOR Gate

Note: If there is no XOR gate to resolve multiple inputs, Bonita Open Solution treats them as XOR by
default. The Step will take the first to arrive and proceed.
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Add Conditions to Transitions

Note that Sales Review has 3 outputs, and each Case of the Process will follow only one of them.
One way to define how a Process will “choose” to follow which path is to define specific Data in the
Details of Sales Review. Then define a Condition for each Transition.

Select Sales Review and in its Details, add Data:
_f Details
2 Sales Review

I:":en eral
Advanced
Data
Actors

| [ type filter text

Connectors

Deadlines - Promote

Forms

Figure 28. Add Data to Details for Sales Review

In the next wizard, define the Data type as a List of options, give it a name, and add the list items.
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0K ] [ Cancel

Add a new variable
Create a new variable for this process (glebal) or this task (local)
Mame* decision
I [ decision ]}
Multiple opticns require a decision
Description
Data type List of options... -
Mame * Approval
Decision to approve, reject, or add more info
Description
Approve
Ao
Remove
(._v, Add an item ﬁ
Item name  Mare Infg|
| ok || ¢ Enter
Name decision
decision

Select
Datatype List

Description Multiple options require a

~

Add

Name (list): Approval
Description:

Decision to approve, reject, or
add more info

Approve, Reject, and More Info

page 22 www.bonitasoft.com | © BonitaSoft S.A.
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Figure 29. Define a list for Sales Review
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Add a new variable

Create a new variable for this process (glebal) or this task (local)

Mame * decision I
I ( decision )
Multiple options require a decision
Description

Datatype |Approval v] ’ Edit ” Rermove

Default value | Approve

Edit Expressicn...

Select
L Default value Approve

| Finish || Cancel |

Figure 30. Select a default value for the List

The list variable now shows in Sales Review -> Details -> Data.

8 sales Review

Gonaal | type filter text
Eﬁ.ranced decision -- Approval
— Add...
Data .
i Ac Edit...
ors
Connectors Remove
Deadlines Promote |
Forms
Figure 31

. Newly created Data (variable) shows up in Data for this Step
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Associate each Transition output from Sales Review with its associated decision Condition. Select
each Transition in turn:

_/ Details
=+ if approved

General Name if approved

Description

Condition decision == "Approve'| | Edit Expression... | [_| Display condition instead of name
Automnatic layout [ f \
Sales Review - Pay:
Name it approved

Conditions decision== “Approve”
Sales Review — Reject:

Name: if not approved

Conditions: decision=="Reject”
Sales Review - More Info:

Name: add a comment

K Conditions decision== “More Info” /

Figure 32. Define Conditions for Transitions

The Name of each Transition now shows on the Process. Click and drag to move them if you wish.

- QSEIES Review if approved = B Pay

add 2 cormment if not approved

Reject
Maore Info

Id
v

Figure 33. Transition Names appear on Whiteboard

Note that Pay has two outputs, too. You’ll return to modify its Details in a similar way. But first...
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Add Details to Process/Steps

Complete the Details, beginning with Data, for the global Process Web Purchase. This information
will be used to generate the form that the customer completes to begin the process. Global data is
accessible to any Step in the Process; while local data is available only to the Step where it is defined.

Add 4 global Data variables: 3 Text and one List. Click on the Pool, go to Web Purchase Details,
select Data, then Add.

F.- {5 | = 52 | -

Add a new variable

Create a new variable for this process (global) or this task (local)

Mame * custamerMame

{ custormerMame )

Customer's full name
Description

Datatype | Text -

Default value -

Enter
Name customerName
Description Customer’s full name
Data type Text

Finish ] [ Cancel l H

Figure 34. Add Data to Details for Web Purchase Process (global variable)

Continue, and Add customerPhone and customerEmail as simple Text variables with no
default values.

BOS V5.2 Quickstart Guide, 10 Jun 2010 www.bonitasoft.com | © BonitaSoft S.A. page 25



(S nontsor

For the last variable, add a List of options.
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-

G

Add a new variable

Create a new variable for this process (global) or this task (local)

Mame ™ products
( products )
Available products
Description
Data type List of cptions...
Mame * Promotional products
Special prices onliine
Description
™
mobile phone
laptop
List*

Add
Up
Do

|

Rem

Fini

(=[=] = |
Enter \
Name products
Description Available
products
Select
Data type List
Name Promotional
Products
Description Special prices
online
Add
TV
mobile phone
laptop

/

Figure 35. Define a list at Process level (global list variable)
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Select a default:

-

G

Add a new variable

Create a new variable for this process (global) or this task (local)

Mame ™ products
{ products )
Available products
Description
Datatype |Promotional_products vl [ Edit ” Remove ]

Default value

-

TV

mobile phone
laptop
${customerEmail}
${customerMame!}

;»|
.

€ bonitasoft

Select
Default value TV

Finish

) [ Cane J

s =

Figure 36. Select a default value for the list

Note that Web Purchase -> Details -> Data now contains 4 global variables.

_f Details

1 Web Purchase

Basal | | type filter text

Data - customerEmail -- Text

Groups customerflame -- Text fdd. |
c custarmerPhone -- Text Edi

g onngdurs products -- Promotional_products = )
Dependencies idstaets
Forms Promote
Application

Figure 37. Newly created Data (variables) show up in Data for the Process
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Now complete the details for the More Info and Pay Steps:

Go to More Info -> Data and select Add:

Bonita Open Solution 5.2 QuickStart Guide

G [ EN
Add a new variable
Create a new variable for this process (global) or this task (local)
Mame * comment
{ comment ]
Additional information supplied by sales employee
Description
Datatype |Text
Default value =
Enter
Name comment

Description Additional information
supplied by sales
employee

Data type Text

Finish ] [ Cancel l

Figure 38. Add Data to Details for More Info

The new variable now shows in Details.

_f Details
2 More Info

Gararal | | type filter text

Advanced - comment -- Text
Data
Actors
Connectors
Deadlines

Forms

Figure 39. Newly created Data (variable) shows up in Data for this Step
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Go to Pay ->Data and select Add.
Add 2 text variables and 1 Boolean variable:

Add 2 text variables:
e Name: creditCardNumber
e Description: Customer®s Credit Card
e Datatype: Text

and

e Name: expirationDate

e Description: Card valid until
o Datatype: Date

e Default value: Now

And Add a Boolean yes/no for the choice of express delivery:

e Name: chooseExpressDelivery

e Description: IT yes - send express; If no - send regular post
e Datatype: Boolean

e Default value: true

_J Details

2 Pay

General | [ type filter text

Advanced | chooseExpressDelivery -- Boolean

Data creditCardMumber -- Text | Add...

expirationDate -- Date Edit..
Actors

Connectors
Deadlines Fromaote

Forms

Figure 40. Newly created Data (variables) show up in Data for this Step
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Here is where you'll define the conditions for each output path.
Add “if-then” Conditions to 2 Transitions.
Select the Transition between Pay and Express Delivery. In the Conditions field, enter

chooseExpressDelivery. This Groovy expression evaluates to
chooseExpressDelivery=true.

_f Details
= if yes
General MName if yes
Description
Cendition chooseExpressDelivery
- Enter
Automatic layout [] Name: IT yes

Conditions: chooseExpressDelivery

Figure 41. Add a Boolean Condition (true) to a Transition

Select the Transition between Pay and Archive. Change its name to “if no.” In the Conditions field,
enter 'chooseExpressDelivery. This Groovy expression evaluates to
chooseExpressDelivery=false.

_f Details

= if no

General Mame if nal

Description

Condition chooseExpressDelivery

Enter
Name: IT yes
Conditions: !chooseExpressDelivery

Automatic layout  [¥]

Figure 42. Add a Boolean (false) Condition to a Transition
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The Name of each Transition now shows on the Process.

g if yes

= Pay *|  Express Delivery

if no

v

-
REiECt ”

Figure 43. Transition Names appear on Process

.

The Process is now complete and ready to deploy/run. Save your Process.
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Run a Process

| g

To Run (deploy) your process, click the Run icon from the Task bar or select Run from the Menu

bar.

After a few moments, Bonita Open Solution will present a series of status messages. The
deployment is successful. Note that you are logged in as the Admin.

The Process can now run Step by Step. The forms are presented in the default Bonita Form and
default Bonita Web Application, which you have not customized (the fields are not presented in any
specified order, they are labeled with the variable name, and so on). After you complete the Run a
Process section, you can return to Bonita Studio and change these forms (see Customize Forms).

- admin | Logout
(5 bonitaopen Web Purchase
o) solution

Case start : Web Purchase

customerEmail ¢
custornueiName :
cistomarhons :

products s .,

Created with Bonita Open Solution

Default customer order form begins the Web Purchase Process Case

Figure 44. Web Purchase Process Case initial Form (customer order form)

At each Step, you can take action as you have previously defined it. (Note that you as Administrator
are testing the manual actions of the Customer (Initiator) at the beginning of the Process and at Pay,
and of the Sales Employee at Sales Review and More Info.)

adimin | Logoul

bonitaopen Web Purchase
2) solution

Case start : Web Purchase

customerEmall ¢ | jll@mail com
customeriame : il Jerry

customarPhone : 5555455

products s .,

Created with Bonita Open Solution

As “Customer”: fill in order form
and Submit

Figure 45. Fill in Web Purchase Process customer order Form to start a Case
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The information entered by the “customer” is presented for approval in the Sales Review Step. You
can now Approve, Reject, or request to enter More Information. Note that the Step candidates
include the individuals you have identified as Sales Employees, plus the admin.

adimin | Logoul

(5 bonitaopen Web Purchase
2) solution

Sales Review

From Jun 9, 2010 637 PM T
SHES BMPIOYES TBCAVES DICET 10 PrOCESEING

Priority. Normal

customerEmall:  jll@mail com

castoemrame : il Jory

cinstomer*hone ©

558-5555
products: T

Created with Bonita npen Sohtion
As “Sales Employee”: select More Info
and Submit

Figure 46. Choose a Decision at Sales Review Step

Bonda User Experence 8

adimin | Logoul

bonitaopen Web Purchase
2) solution

More Info

From Jun 9, 2010 640 PM T
Saes Employee enters acdiional information

Priority. Normal

customerEmall : Sl mail com

castoemerame : il Jory

cinstomer*hone ©

555-5555

products: TV =|

Check credit card number

comment |

| Subeit

Created with Bonita Open S0/
As “Sales Employee”: enter additional information
and Submit

Figure 47. Fill in Form presented at More Info Step
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Bonda User Experence 8

- adimin | Logout
(5 bonitaopen Web Purchase
2) solution

Sales Review

From Jun 9, 2010 642 PM T
SHES BMPIOYEE TBCANVES DICET 10 PIOCESEING

Priority. Normal

customerEmall : Sl mail com

castoemerame : il Jory

cinstomer*hone ©

555-5555

products: TV =|
docision |
Created with Bonita Open Solution

As “Sales Employee”: select Approve
and Submit

Figure 48. Fill in Form presented (again, after iteration) at Sales Review Step

Bonda User Experence 8

adimin | Logoul

bonitaopen Web Purchase
2) solution

Pay

From Jun 9, 2010 643 PM T Priority. Normal
Cusiomer completes cread cand payment form

customerEmall : Sl mail com

castoemerame : il Jory

cinstomer*hone ©

555-5555

products: TV =|

chooseExpressDolivery 1+

crodiCardNumber & 1734 5678 9123

expirationDate ©  October 14 2010

| Subemit

As “Customer”: Fill in Credit Card Number and Expiration
Date, select Express Delivery and Submit

Figure 49. Fill in Form presented at Pay Step

Note that at this step, the Form would be presented to the Initiator, but by default the admin has
access to activate it.
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bonitaopen Web Purchase
2) solution

The information has besn submitted.
T continue, cpen your inbax.

Crealed with Bonda Open Sohdion

Process completed. Go to User Experience

Figure 50. Web Purchase Case completed

Click on Bonita User Experience (circled in red) to open.
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Complete a Process Case

Use Bonita User Experience to run multiple Cases of this Process. Note that you can also open the

® ]
User Experience by clicking on the User XP icon 'on the Task bar in Bonita Studio.

Your inbox now contains a record of all the actions you have been involved in. You can look at these
actions at any time.

hnm. en . Onghsh |~ | Preferences | About | Logout
(5 solution Bonita User Experience
b (1) U Forum
Avchive| Mark as read | Move to ¥ | Labals ¥ | More actins ¥ Rafresh J=AER b
ST Gwiki
Select: All Read Unread Stamed Unatamed Nona & Blog
My cases (1)
@ e Wb Purchase - 82 3~ Pay G/9/10 6:44 PM
ot
L] U GuickStart Guida
= Stant a case U user & Reference Guide
Wb Purchase I (5 Tutoriats |
® Dashboard
® Aamin
EProcssses
Cases
Sallings:
Reporting
Usors
Yy S Yy o [ Click on Web Purchase in the inbox to expand it
Agchive Mark as read | Mova to ¥ Labais ¥ | Moe actions ¥ Hofresh

Figure 51. Bonita User Experience with completed Web Purchase Process test Case

Click the case to expand it.

bonitaopen 4nglish [+ | Brafarancas | Absut | Lagaut
solution Bonita User Experience
Join the community
Inbox M
=< Back 10 I0bOX Aschive|Mark a3 read | Move to ¥ |Labets ¥ | More actions ¥ " Porum
Stared & wika
@ Web Purchase - #2 (4) wes X & Blog
My cases
started by. admin Simpke ilern purchase from Web site - Wlorial e B0 6:40 PM
Unread Getting started
* more ® = Sales Reviw(HdmMin) - Sales smplaysn rcnints ofder far processing S0 640 PM U quickStart Gusde
= Start a case & user & Reference Guide
Web Purchase b Comments (0) Add & Tutorials
® Dashboard
® = More Ifo (admin) - Sales employee enters additional informatic 81910 8:42 PM
B sramin
Erocestes
Canes Commants (0) Add
Seltings
Beporting & = Sales Review(admin) -5 G910 6:43 PM
Usors
Comments (0] Add
® — Pay(admin) - Customer completes creadit card payment form G910 6:44 PM

Pay
customerCmall ; Jill@mail com
customeriame : Jill Jemy

custiomarPhone : S55-5555

products : TV
chooseExpressDelivery : yes
creditCardNumber : 1234 5678 9123

expirationDote : June 9, 2010

Comments (0] Agd

<< BCK L0 DO Avchive Mark 35 rad

The Web Purchase Process shows the Steps executed in your test Case ]

Figure 52. Web Purchase Process test Case expanded
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To see the entire Process, including Automatic Steps, Start, End, and Gates, go to Admin -> Cases on
the left side of the window. Again click on Web Purchase to expand it.

Bonita User Experience

Q
InBox M
Modify] Delete| More actions V- Redrash & Farum

& wiki

(5 bonitaopen énglish | v | Breferences | Abaut | Lagout
solution

© Web Purchase - 2 (10) tex X & Blog
SLANAG By AAMIA Simplt: f6m PUICAISH from Wb Site - Tuloral & B0 630 P
& Start1() - G910 640 PM & QuickStart Guide
18 User & Reference Guide
Comments (0) Add & Tutarials
& Gatel()- W10 G40 PM

Comments (0] Add

® = Sales Revibw{RdMIn) - 53068 aMpiyeh FCHNVES Grder 1 processing G0 640 PM

Comments (0] Agd

® = Mot Infa (admin] - Sales smgloyes aners acditonal infamnaticn A0 642 PM

Commants (0] Add

® Gawl () A0 642 PM

Commenis (U) Add

& = Sales Review (@dmin) - Sales ernployes e 910 8.43 PM
Commants () Add
& — Pay{admin) - Customer completes creadit card payrment form /9110 8:44 PM
Commaents (0] Add
® Express Delvery () - Send ilem via 3-day delivery /910 6:44 PM
Comments (0) Add
& Aqchive () - System archives re ansaction /10 6:44 PM
Comments (0] Add
® Endi(- 610 6:44 PM
End1
customarEmail : Jill@mail com
customeriame : Jill Jamy
customerPhone : 5655565
products : TV
Comments (©) Al [ Click on Case Admin to see the Case history ]
Matity| Cancel | Dalete | More actions ¥ Refiest

Figure 53. See the entire Case History with the Admin function
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To run this Process again:

Bonita Open Solution 5.2 QuickStart Guide

m‘m en . |0n9tsh = | Prafarances | Absut | Logout
S somion Bonita User Experience
Jain the community
Inbox =10t & Forum
e Aechive, Mark as iead mwt_umv_woauwt Hefresh & wiki
Sewct All Hoad Untead Stamed Unstamed None $ Blog
. ¢ weex\Wab Purchase - #2 83 = Fay 60110 6:44 PM
e
- more b QuickStart Guide
® start a case G User B Reference Gude
R Start 3 case Web Purchase - 1.4 & Tutorials |
® Dashboand
B admin
Lanes
— [ Click the Case Web Purchase under Start a case to run another ]
Usiors

P

Figure 54. Start another Case for the Web Purchase Process

The Process starts again with a new Case.

(5 bonitaopen

solution Bonita User Experience

=< Back 10 Inbox

Case start : Web Purchase
customerEmail =
customeriame ;
customarPhone
products = TV
Processes [Subenit |

onglish | = | Eraferences | About | Logout

Join the community

& Forum
& Wik
fie] L Blog

(s quickstart Guide
U user & Reference Guide

& Turorials

Figure 55. Fill in web purchase process customer order Form to start a new case

Try running several Cases to try different choices at each Step.
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Customize Forms

To customize the way information is presented to the end user in the four Bonita Open Solution-
generated forms in this tutorial example, return to Bonita Studio.

Add a case start Form

The first Form presented in this process, Case Start: Web Purchase is the one that begins this
process. To customize it, click on the Process Pool. Go to Details -> Forms -> Add.

A wizard appears with all of the Data variables available for this Form.

Create a new Form

Create a form with selected data

Mame L“."eb Purchase (Web_Purchase)

Description

Add widgets based on...

| select All | | Unselect Al

[¥] customerEmail  -> Text
[¥] customerMame -> Text
[¥] customerPhone -» Text
products -» Select

Finish ] [ Cancel

Figure 56. Select Data to appear in new Form

For this example, leave all choices checked and Finish to continue. A default version of the Form will
appear, along with the Details panel for the Form.

/ Details

& Web_Purchase

General Mame Web Purchase ( Web_Purchasze )

Validators

Atione Show pagetitle V]| Web Purchase - | [C] Allow HTML
Description

Page Template Erowse| Clear

Figure 57. Details panel for Web Purchase Form
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To see the entire Form, close the Details and Overview Panels (click on the X in the upper right

corner of each panel).

W Web Purchine %

1 o Palstte

[#] Cheskbes

(=] Checkbex List

[ Dure e customerEmail

(5 Durstien

customerName I

customerPhone T

ISMID (% )7 pesc

o Web Purchase

Vahdators.

Descrigtion

Page Template

Girnerad Hame Web Purchase

Actions | Shew pege title 9] | Web Purchase

{ Web_Purchase )

= | [7] Allow HTMIL

Figure 58. Close Details and Overview panels to see the entire Form

@@ @
© customerEmail [T |
@

(] customerName [T

@

(&) customerPhone | I

@

© products \
@

©

@

Figure 59. initial Web Purchase Form ready to customize

Each Data field in the Form is presented in a widget. You can customize the order and presentation

of each widget in the Form.
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Reorder widgets in Form

It's easier to move widgets when there is an empty space. Add one to the top of the Form by
clicking on the “add a row” symbol @ at the top left:

‘g,'
@
@®
@
&

S} customerEmail I e customerEmail

@ @

S customerName I S customerName

@ @

@ customerPhone | © customerPhone
@ ®

@ products N (&) products

@ @®

S Submit e Submit

Figure 60. Add a blank widget to the top of the Form

Now you can click and drag the “customerName” widget to the first row of the Form.
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® [
AL AL

@

Q@ customerName | I

]

S

e customerEmail [T

i

Gy

=

L

=y

I/

e customerPhone ||

i

S

S products -

)

Ry

o

]

S

Figure 61. Reorder the widgets in the Form
Click and drag the other widgets into the order you want.
® fan)
@ =
S customerName [1
® @®

@i @
© customerEmail [T S customerName 1
@ i @ i
© customerPhone ] S) customerEmail 1
@ ®
e products © customerPhone [
@ @
Ly

m
W

@
&
-
d

© ©

@
&®

@
&

Figure 62. Remove the extra widget

To remove the extra widget, click on the “remove a row” symbol 6 at the bottom left.
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Customize widgets in Form
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Now you can customize the details for each widget. Begin with customerName; click the widget and
go to Details. (You may need to restore the View to see the Details panel again. Go to the Menu bar

and select View -> Reset view.)

_/ Details
[[%<] customerName
General Mame customerMName
Options
Data | Show label  [¥] | Full Mame
Validators BT
Grid
Appearance
Description

Field Type |TextBox  ~|

{ custemerMame )

- | [ Allow HTML

Enter

Show label: Full Name

Tool tip: please enter first then last name
Field tvne Text Box

Figure 63. Customize General details for widget

Go to Options and select Is mandatory.

_J Details

[T5] customerName

General
Options
Data
Validators
Grid

| Is mandatory

Appearance

Html Attributes

e.g. onclick="alert(tezt" readoniy="readonly’

]l

Figure 64. Indicate that the Customer Name field must be completed in the Form

There are no changes to Data, Validators, Grid, or Appearance for this widget. Continue to the next
widget, customerEmail. Change the Show label field to Email address.

Go to Details -> Validators -> Add.

BOS V5.2 Quickstart Guide, 10 Jun 2010

_J Details
[T5] customerEmail
General | [ypefiltertedt | ok | Name customerEmailValidatorl
Options customerEmailValidatorl |Create...| ;

| ——— \Validator Type | Mail ~| | Edit *
Data |Remo\re|
Validators Parameter
Grid Error Message  this does not appear to be a valid email address *
Appearance H

[¥] Add the default Validator for this widget Choose
Validator type: Mail
Enter

Error message this does not appear to
be a valid email address

Figure 65. Add a Validator
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If a red X appears in the field, save the Diagram and it should resolve and disappear.

Bonita Open Solution 5.2 QuickStart Guide

There are no changes to Data, Grid, or Appearance for this widget. Continue to the next widget,
customerPhone. Go to Details -> General.

' Details

[T5&] customerPhone

General MName customerPhone ( customerPhone )
Options
Data | Show label  [¥] | Phone number - | [C] Allow HTML
Validators | g -

| Tooltip please enter a number we can reach you at duringw ~
Grid
Appearance 2 Enter

Description

Show label: Phone number
Tool tip: please enter a number we can

Field Type |TetBox | ‘ reach you at during working hours
Field type Text Box

Figure 66. Customize Details for another widget

There are no changes to Data, Validators, Grid, or Appearance for this widget. Go to Options and
select Is mandatory.

Continue to the next widget, products. Go to Details -> General.

/' Details
[ products
General ~ Mame products { products ]
Options
Data Show label  [¥] | Prometional products available - | [ Allow HTML
Validators | Tooli =
Grid
Appearance
| Description
Field Type
Radio . Enter
| Show label: Promotional products available

Field type Select

Figure 67. Create a drop-down list for a list of choices

For this Data variable, a drop-down list allows the user to select more than one item from a Data list.
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Farn) Farn)
I/ I/

[

o

S] Full Name

[

o

S] Email address

[

L/

@ Phone number

[

L/

@ Promotional prod...

[

I/

@ Submit

Figure 68. Customized Form

Preview the Form you have created by selecting Preview from the Task Bar.

1

bonitaopen Web Purchase
2) solution

Web Purchase
Full Mame  ${custometiame)
Email address  5customer mail]
Phone number ${customaPhona)

Premotional preducts avallable

Created with Bonita Open Sohution

Figure 69. Preview customized Form (to initiate Process)
Close the Form and save it by clicking on the X on its tab.
Add a Sales Review Form
Unlike the “live” Form presented to the Initiator to start this Process, the Form at the Sales Review

Step primarily serves to carry data forward for review. There is only one “live” field for the Sales
Employee, the “Decision” choice.
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Create a Form here to do this.

Bonita Open Solution 5.2 QuickStart Guide

Go to Sales Review -> Details -> Forms -> Add. Again select all Data available here to carry into the
Form.

& o|E] %

Create a new Form

Create a form with selected data

Mame Sales Review (Sales_Review)

Description

Add widgets based on...

decision - Select
customerEmail  -> Text
custornerMame - Text
[¥] customerPhone -> Text
products -> Select

[ Finish I [ Cancel I

Figure 70. Select widgets to show in new Form

Add a new space to the Form just above the Submit button. Drag and drop the decision widget to
this space. Re-arrange the other widgets (see Figure below) and delete the resulting empty widget.

@ fn)
r LS
]
L/
@ customerName | 1
i
Gy
e customerEmail I
=y
U/
© customerPhone | 1
i
L/
@ products
Fi
Ly
© decision

6
Figure 71. Arrange widgets in order
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Reformat the widgets for customerName, customerEmail, customerPhone, and products to carry
forward data already entered by the Initator.

Click on the customerName widget to see its Details panel. Here you can change its Field Type from
TextBox (live) to Text (read only).

_/ Details
[55] customerName
General MName customerMName { custormerName )
Options
Data | Show label [¥] | Custormer Name - | [ Allow HTML
Grid |
Appearance Description
Field Type  |Text -

Message =

Password |

= Enter

il Show label: Customer Name

Field type change to Text

Figure 72. Change widget from TextBox (live) to Text (read only)
Repeat this for customerEmail, and customerPhone.

To change products to a read-only text field, you will need to redefine a widget.

Use the @ to insert a new widget. Click and drag a Text widget from the Palette into the new space.
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[==] Checkbox List @ Customer Email |A:|c

Date
(5 Duraticn
%3] Password
4 List

(@ Radio
ESeIect
Tex‘tBox

I =1Tedirea
| = Message

[ ok | Submit
| 44 | Previous
[ | Mext

S Customer Phone  |Abc

S products Z

@ Labell Abc

[ | Simple Button

[Z] File

[T_ Hidden

@ decision -

6

Figure 73. Add a new Text widget

Click on the new widget, go to Details -> General and rename the widget and Label.

_J Details
[75] products
General Name products { products )
Options
Data | Show label [¥] | Products selected = | [] Allow HTML
Grid |
Appsassnce | Description
Enter
Name: products
Field Type |Text =

Show label Products selected

Figure 74. Rename new widget

Delete the old products widget.
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In the new Products widget, go to General -> Data. Select S{products}.

[ | products

Pem— | Initial value = | ${products} - | [C] Allow HTRML
5 | S customerMame} -

Oplioes | SlcustomerPhone}

Data Siproducts] ( default value = TV ) E;E‘

Gnd Edit Expression... x

Appearance

Figure 75. Select data value for Products text field

Last, go to decision -> General. Choose Radio as the Field Type. Radio allows only one choice from a
Data list. This is the only “live” field in this Form.

_F Details
(@ decision
General Mame decision ( decision )
Options
Data | Showlabel [¥] | Decision ~ | [ Allow HTML
‘u"a!ldators | Tooltip =
Grid
Appearance
| Description

CheckBox Group
List

Figure 76. Choose Radio as the Field Type for decision
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)
S
) -
s
S Customer Name
)
S
S Customer Email
)
o
S Customer Phone
)
1
S, Product selected
i
I/
— ..
-~ Decision

6

)
S

Abc

|A:|c

|A:|c

Bonita Open Solution 5.2 QuickStart Guide

Figure 77. Customized widgets in Sales Review Form
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Preview the Form you have customized.

I

|lll IIIIB(I Ilﬂl'l Web Purchase
) solution

Sales Review

From To Pricrity

Customer Name S{customarfiama)

Customar Email ${customerEma]
Customar Phone Slcustamedhans]
Products selected S{products)

dacision . dem?
Hem?

Figure 78. Preview customized Form (for Sales Review Step)

Customize the Form in More Info in the same way. Leave the field for comment (Add comment) as a
live TextBox.

The Form for the Step Pay will again be presented to the Initiator, so you can add a widget to
summarize the customer’s order.

Click on Pay and go to Details -> Forms -> Add.

When the Create a New Form wizard appears, select only chooseExpressDelivery,
creditCardNumber, and expirationDate.

Re-arrange the widgets as shown in the figure below. Add a new widget by clicking and dragging the
Message widget into the top spot.

W PayForm ¥ " PayForml X
4 57 Palette
@ @
[ @ @
@
V] Checkbox ~
= | Checkbosx List
o
i Date ~
Duration
FEH Password @ ¢
= 7 List
© Radio @ creditCardNumber ||
<) Select
1 sbe | TextBox @
@

I="| TextArea

S expirationDate 01/01/2010
@

4| Previous -

| Next

2| File © chooseExpressDel... v

4 Image

T\_ Hidden )
S Submit

@
&b

Figure 79. Create a Form for the Pay Step
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Go to Details and change the following widget labels:

creditCardNumber:

expirationDate: Expiration Date

Credit Card Number

Bonita Open Solution 5.2 QuickStart Guide

chooseExpressDelivery: Do you want express delivery? Check if yes:

For the new Message widget, go to Details -> Data. For Initial value, select Edit Expression. Create
a Groovy expression to present a message in the Form.

page 52

_J Details
[==| MessageBox1

GEneral | Initial value -

3 Y customertame) -
.[}ata i S custormerPhone}
Grid _ Sproducts} ( default value = TV) ,'__:|
.Appearance Edit Expression... -

G ® -

Process Variables | Select...

g St

="Thank you, ™
products +
n

Please enter

+ customerName +", for your order

credit card information "
y method.™

"and select a de

Functions

type filter text

Categories

Bonita (1)
Collection (43)
Mumber (64)

String (144)
Others (439)

| Save ‘ | Open | Groovy Quick Start

v| Bonita Variables |Select‘..

== < <= = »>= > And Or Not True False [ )

;

Documentation

Set Variables

4 b

(

oK } [ Cancel |

Figure 81. Enter a Groovy expression to be evaluated and presented in the Message
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Preview the Form you have customized.

- |
Illlnll_allllell Web Purchase
o) solution

Pay

From: To: Priority:

${"Thank you, " + customeriame +", for your order of a " + products + . Please enter your credit card information " +
"and select a delivery method."}

Credit Card Number 3H{creditCardNumber}
Expiration Date

Do you want express delivery?
Check if yes

Created with Bonita Open Solution

Figure 82. Preview customized Form (for Pay Step)
Close and Save the Form. Save your Process as Web Purchase Diagram 1.4. Runit.

You should now see the Forms you have designed presented in the default Bonita Open Solution
Web Form.

Bonda User Experence 8

- adimin | Logout
bonitaopen Web Purchase
2) solution

Web Purchase

Full Nama
Ermail s

Phone number

Promotional products available 1

Crealed with Bonita Open Solutiol

Figure 83. Customized Form (fields) presented in Bonita Open Solution default web Form
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Summary
You have used only some of Bonita Open Solution's functions, specifically:

The graphical interfaces of Bonita Studio, to create a complete Process by
e drawing Steps and assigning them as Human or Automatic;
e assigning Actors to Human Steps;
e adding global variables to the Process and local variables to Steps, which in turn have been
used to create interactive forms;
0 defining text and list variables;
0 defining a Boolean variable;
e defining Conditions on Transitions to manage multiple output choices from a Step; and
e defining a Gate to manage multiple inputs to a Step in an iteration.

The default Forms interface of Bonita User Experience:
e to Run a completed Process and enter information into the interactive forms created from
your variables.

The e-mail like interface of Bonita User Experience:
e to see the completed Case Steps;
e to consult the Case history
e to Run an additional Case (or two, or several) of your Process.

The Form Builder customization feature of Bonita Studio:
e to select which data fields to present in a Form
e to configure how those data fields will be presented to the User.

If you explore a bit more in Bonita Open Solution, you will find other functionalities not addressed in
this QuickStart - for example, in the Details for a Step, you can define Connectors to link to external
databases and to messaging systems, and much more.

Feedback, Questions, and More Information

For an expanded explanation of the functionalities in Bonita Open Solution, see the Bonita Open
Solution User and Reference Guide.

We welcome your feedback. Use the BonitaSoft Forum to let us have it!
(www.bonitasoft.org/forum)

The BonitaSoft Forum is the place for your questions too. And check out our Bug Tracker, Source
Code, and more.
(www.bonitasoft.org/index.php)

Join the BonitaSoft Community and get our Newsletter, access to advance information, and more.
(www.bonitasoft.com/community/join.php)

For more information, contact us at BonitaSoft.
(www.bonitasoft.com/company/contact.php)

Have fun with Bonita!
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