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1 Document Goal

The goal of this document is to provide you with an introduction on using Spagic platform by designing, deploying and

monitoring a sample process after the Spagic installation and configuration.

2 Versions History

Version/Release n°: 1.0 Date 29/06/2007
Description First release (English version)
Version/Release n°: 1.1 Date 03/08/2007

Description

Added the steps for the creation of the backup database.

Version/Release n°:

Description

1.2 Date 03/10/2007

Changed the configuration steps for datasources: from the release 1.0.1 they are
JNDI based.

Section 5.4: added the instructions about the taxonomyVisible attribute.
Section 5.4: added the instructions for installing the JDBC driver in Tomcat.

Section 5.1: changed the user for the backup database.

Version/Release n°: 2.0 Date 21/01/2008
Description Updated to Spagic 2.0.0.
Version/Release n°: 21 Date 29/07/2008
Description Updated to Spagic 2.2.0.
Version/Release n°: 2.2 Date 10/10/2008

Description

Update some sections relative to freebXML
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3 Introduction

Spagic is a solution composed by a set of visual tools and back-end applications oriented towards design, realization,

deploy and monitoring of ESB infrastructures adherent to the SOA paradigm:

Spagic Studio: Eclipse environment that consents the use of a single interface in order to create components
and processes managing the entire development cycle: design, service registry configuration (UDDI & ebXML),

metadata management, WSDL generation, rules definition, mapping, data integration (Talend Open Studio

generated job), custom services and orchestration.

Enterprise Monitoring: for the monitoring, through Ajax interface, of the system information (system
monitoring), services & processes (services monitoring).

Spagic Service Manager: using the open source ESB ServiceMix project and the Spagic listener it is possible
to manage correlated processes and information during the services orchestration. New binding components
have been implemented in synchronous modality also.

The platform supports also execution of BPEL processes through the open source Apache ODE BPEL engine.
Persistence layer - MetaDB: the different services and the rules of process and extraction of the relevant
information are described and classified through a metadata system. Therefore the repository manages the
entire life cycle of the components and traces their use in order to optimize the monitoring activities. The

registration is made through Spagic studio and at runtime on Service Manager by means the specific listener.

The document was organized in the following way: there is a first section related to the Spagic complete installation (in

order: MetaDB, ServiceMix, Spagic Studio and Spagic Console), then there are the sections related to design, deploy,

run and monitor of a very simple process.

For more details about Spagic Studio environment see the document Spagic Studio User Guide.doc.

For more details about Spagic Console, see the document Spagic Studio User Guide.doc.
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4 Requirements

Required Tools URL for download/Notes Spagic Spagic Console
Studio
Database MySQL
Required Required
Oracle
Eclipse Europa for Java EE http://www.eclipse.org/downloads/moreinfo/jee.php .
Required
Developers
GraphViz http://www.graphviz.org/ Required
juDDI http://ws.apache.org/juddi/ Optional Optional
freebXML http://ebxmirr.sourceforge.net/ Optional Optional
JDK 1.5.0_11 or later http://java.sun.com/ Required Required
Apache Tomcat 5.5.17 http://tomcat.apache.org Required
Mozilla Firefox 2.0.0.x http://www.mozilla.com Required

5

Installation

The following steps allow you to install the entire Spagic platform.
In this document we will use the notation {SERVICEMIX_VERSION} for referring to the ServiceMix release used.

Current ServiceMix release is 3.2.1.

5.1 Persistence layer — MetaDB

To setup the metadatabase follow these steps:

1.
2.

Install MySQL Server (release 5.0 or higher) or Oracle (release 9i or 10g) or PostgreSQL (release 8.1)

Create a new schema “spagic” and a user “spagic” with password “spagic” and the permissions for writing into the
schema.

Generate the tables using the “spagic-metadb-<database type>.ddl” released in the spagic-metadb package.
Launch the scripts “setup-<database type>.sql” released in the spagic-metadb package, to load all the configuration
tables.

Optional step: install the backup database for monitoring data, if you want to clean periodically the monitoring data.
Create a new schema “spagic-bck” and a user “spagic-bck” with password “spagic-bck” and the permissions for
writing into the schema.

Generate the tables using the “spagic-bck-<database type>.ddl” released in the spagic-metadb package.

If you installed the MySQL Server and the processes‘s messages contain the attachments bigger than 1 MB, you
have to configure the variable max_allowed_packet = 16M into the file: {MySQL Server path}/my.ini and restart the

server.
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5.2 Service Manager

To install the Service Manager follow these steps:

1.

To install ServiceMix, copy the folder “apache-servicemix-{SERVICEMIX_VERSION}, released in the spagic-
service-manager package, into your Spagic installation folder (you should create this new folder). All base
components are already installed (component  hitp, tcp, jms....) into  “apache-servicemix-
{SERVICEMIX_VERSION}\hotdeploy”. The monitoring system, composed by a listener, monitoring all the
exchanges handled by ServiceMix, and a process, listening for the queue populated by the listener, is already
installed and configured.

If you installed the database on a different machine from the ServiceMix machine then configure the “apache-
servicemix-{SERVICEMIX_VERSION}\conf\indi.xml” file so that the datasource “java:comp/env/jdbc/metadb” links to
the database just created.

If you installed an Oracle database instead of MySQL then configure the “apache-servicemix-
{SERVICEMIX_VERSION}\conf\hibernate.cfg.xml” file so that the property “hibernate.dialect’ has the value
“org.hibernate.dialect.OracleDialect”.

To launch ServiceMix, launch the command “bin\servicemix from the  apache-servicemix-
{SERVICEMIX_VERSION}” folder.

5.3 Spagic Studio

To install Spagic Studio on client machine follow these steps:

1.

Get graphviz installation package from http://www.graphviz.org/ and install it. If you’re using windows, simply run

graphviz executable file and follow the wizards. During the installation steps take in mind the location where the

executable dot program was installed.

In Windows (ltalian language) default installation graphviz will install the dot program in
C:\Programmi\ATT\Graphviz\bin\dot.exe

Spagic Studio is distributed as an Eclipse application, so you have simply to get it from Spagic distribution (from the
package spagic-studio) and unzip it.

In this document we will refer to the Eclipse folder as SPAGIC_STUDIO_HOME.

If you want to create Spagic Studio from scratch, instead of using the distribution package, please refer to the

document “How to cook your Spagic Studio”.

Spagic Studio needs to connect to Spagic metadabase. Ensure that the database is running and that permissions

are configured properly on database server.

Optional step: an installation of Tomcat with JUDDI installed, if you want to publish your services in UDDI
Registries. To install JUDDI refer to its installation documentation. After the installation, it needs to create manually
in the “publisher” table a new publisher with “publisherld” set to “eng”, the same value configured in the Service
Registries List Wizard on Spagic Studio (for detail see the document “Spagic Studio User Guide”, section “Manage

Process Publication on Service Registries”).
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5. Optional step: an installation of Tomcat with freebXML installed, if you want to publish your services in ebXML
Registries. To install freebXML refer to its installation documentation

(http://ebxmlrr.sourceforge.net/wiki/index.php/Install)

After the installation you should execute the following steps:
1. launch the omar web application (http:/localhost:8080/omar);

2. create a new user account following the instructions visualized on the web page (use alias: eng, password:

engeng);

3. import the key (*.p12) generated to your Web browser following the instructions visualized on the web

page;

4. import the key (*.p12) into the keystore located in the <OMAR_HOME>/ jaxr-ebxml/security directory, using
the omar GUI application in the following way. Open the command line, run the command build

run.browser, select the Registry Location and click the following button:

= Repgistry Browser Java Ul

File View Help

3 s e

Registry Location: hitn//localho sTEOE0Omatregistrysoap

AT
Nicrmman: |

The Registry Browser Java Gui will display the following window:

Ky Hegfstratiss Wizesd El

Dighal CorlBcaln Isformatisn
L T S 0 il e Pors smi B 2
g
il e el e ) i e B !
Clhvariie Filk 10 it Train
CPrap alinl- ppl
| OH | s

The “Keystore Alias” field has the value “eng”, the same value configured in the Service Registries List
Wizard on Spagic Studio (for detail see the document “Spagic Studio User Guide”, section “Manage
Process Publication on Service Registries”). The “Private Key Password” field has the value “engeng” (the

same configured on Spagic Studio), the “File to Import’ contains the path of the file *.p72 just generated.
Note: the keystore password is “ebxmirr’.

5. Copy the keystore containing the key with alias eng, from the <OMAR_HOME>/ jaxr-ebxml/security
directory to keystore directory located into the “org.spagic.ui’ plugin in SPAGIC_STUDIO_HOME/plugins

To start you only need to launch eclipse.exe in SPAGIC_STUDIO_HOME.
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5.4 Spagic Console

To install Spagic Console follow the next steps:

1.
2.

P -

Install the Apache Tomcat 5.5.17; to install it refer to its installation documentation (http://tomcat.apache.org).

Install the database JDBC driver for the database you are using in the Tomcat common\lib folder:

e If you are using MySQL, please use mysgql-connector-java-5.0.7-bin.jar or later.

e If you are using Oracle 9i/10g use the JDBC driver for JDK 1.4 and Oracle 10g (it works also on 9i). The driver
name is ojdbc14.jar.

You can retrieve both the drivers from the /ib folder of the ServiceMix released in Spagic.

Install the web application SpagicConsole: you should copy into apache-tomcat-5.5.17\webapps folder the

Spagic.war released with Spagic.

If you used a configuration different from the default suggested in this document, before starting Tomcat it 's

necessary to verify the following Spagic Console configuration files and update them:

e If you installed the Console on a different machine from the ServiceMix machine:

a) Update the file \SpagicConsole\WEB-INF\conf\imx\servers.xml to set the jmxUrl to the URL for connecting
to ServiceMix by JMX. The URL is written by ServiceMix on its console, on the startup.

b) Update the file \SpagicConsole\WEB-INF\conficonsole\console.xml to set the locationRestartWs,
locationBackupWS and locationDeleteWS parameters to the URL where you installed ServiceMix. These
are the URLs of the restart, backup and clean database operations.

e If you installed the database on a different machine from the Tomcat machine, update the file
\SpagicConsole\META-INF\context.xml so it could link to the Spagic database (with the JNDI name
jdbc/spagic).

¢ If you installed an Oracle database instead of MySQL then configure the “\SpagicConsole\WEB-
INF\classes\hibernate.cfg.xml’ file so that the property “hibernate.dialect’ has the value
“org.hibernate.dialect. OracleDialect’.

e |f you used UDDI:

a) Update the file \SpagicConsole\WEB-INF\classes\Serviceregistry.properties to set the URL of jUDDI
application.

b) Configure the “\SpagicConsole\WEB-INF\conf\console\console.xml” file so that the attribute
“taxonomyVisible” has the value “TRUE” and the attribute “serviceAttribute" has the value “uddi’

e If you used ebXML:

a) Update the file \SpagicConsole\WEB-INF\classes\ jaxr-ebxml.properties to set the URL of freebXML
application (jaxr-ebxm.soap.url property)

b) Configure the “\SpagicConsole\WEB-INF\conf\console\console.xml!” file so that the attribute

“taxonomyVisible” has the value “TRUE” and the attribute “serviceAttribute" has the value “ebXML”
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6 Developing a Process

Spagic Studio is an Eclipse environment that allows the use of a single interface in order to create components and
processes managing the entire development cycle. For the details, see the documents Spagic Studio User Guide and
Spagic JBI Components.doc.

In this section we’ll shortly describe all steps for developing the processes using a simple example.

6.1 Create a Spagic project

Open Spagic Studio and create a workspace for working, for example call it SpagicDemo.

As first step, configure the Spagic Studio Preferences from Window->Preferences->Spagic Preference, set the attributes
for the MetaDB, the graphviz application, select the service registry.

To create a new project, select File->New->Project->Spagic 2.0->Spagic 2.0 Project, insert a Project Name, StartSpagic,
click Finish.

In the workspace, the project just created has a standard structure containing the followings directories:
e Bpel: contains all BPEL files and artifacts generated when using BPEL technology;
¢ Deployables: contains the following files produced by Spagic Studio:
O <Process name>_v_<version>-sa.zip: service assembly to be deployed in ServiceMix.

O <Process name>_v_<version>.deploy: deploy file necessary to publish the process on the Spagic
MetaDB, if you don’'t want to use Spagic Studio but a Spagic command line tool (necessary for example

when migrating the processes from test environments to production environments).

O <Process name>_v_<version>.properties: optional file created if within the processes are used some

configurable parameters.

¢ Integration Process: contains all Spagic file describing the service assembly in terms of endpoints and flow

between them;
e Mappings: contains resources used by the mapping component. Almost of this resources will be XSLT file.

e Scripts: contains resources that are used by Scripting Components. At the moment groovy is the language for

the scripting so this folder will contain groovy file;
e SemanticRules: contains resources used by Semantic Validator Component;
« SyntaxRules:contains resources that are used by the Syntax Validator Component;

e WsdIFiles: contains resources automatically generated by Spagic Studio if the process contains entry endpoint

relative to HTTP Component configured to be a SOAP Provider.

6.2 Design the process

To define a new process, select the Integration Process folder, open the context menu and New->Other->Bpmn
Diagram. Insert a file name, for example firstProcess.

When the file has been created in the Integration Process folder, the visual Spagic editor will be opened.
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To design a very simple process, select, from the component palette located at the right of the editor, an Empty Start
element and put it to the editing area. Then put an element Empty End on the same process, and link the start element

with the end element.

Double click on the pool name and change it to “firstProcess”; assign also a name to the start element (“start”) and to the

end element (“end”).

The result should be similar to the following screenshot.
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Before proceeding you have to add 2 views to the Editor: choose the command Window->Show View->Other and select

the views Intermediate Model and Observable Attributes.
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Now you are ready to choose the technology that Spagic will use to generate the process: remember that Spagic 2 now

supports more technologies (JBI and BPEL), and it's in the next step that you select the proper technology for your

process.

According to the technology that you’ll choose you have to follow different paragraphs:

= For JBI read [6.2.1] JBI Technology

= ForBPEL read [ 6.2.2-6.2.2.1 ] BPEL Technology, Complete with further technical definitions

=  For JBPM read XXXX JBPM Technology

6.2.1 JBI Technology

Select the pool firstProcess (it should be unique) and in the view Properties select the Tab Technology: here you should

found a combo containing the supported technologies.
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Choose “JBI — Apache ServiceMix” and select Bind to Runtime: now your process has the JBI technology associated,

and you are ready to use the services provided by this specific technology.
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In the next steps you have to specify which specific technological services are bound to the steps of your BPMN

diagram.
To do this, select the view IntermediateModel: you should see the list of all services available for JBI.

Open the StartService category and drag the service JBI-HTTPInputBindingComponent on the step start.
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Spagic Studio asks if you want to associate this BPMN step with the JBI service (also called Binding) JBI-

HTTPInputBindingComponent that is an HTTP Binding Component configured as In-Only.

¢

N

~

Atkach Service[StarkService] with Binding (JBI-HT TRInputBindingComponent) on on Empty Skark Event skark |

start end [ Intermediar,,, A
.
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You are ready to configure the HTTP BC of the first step.
Select the start step and configure all the properties in the Properties tab, in the item IM-Model.
In the firstProcess sample you need simply to insert the value http://0.0.0.0:8195/firstprocess in the property Uri.

# b T e Bt oes s Thest Fyraa oo s b ol s ot - Bolissr PR .-J.ﬂ]!l
s £ uq-n Mgty Zswth  Prames Bun Wircow e
I = (-5 v e - N e S T e~ o R W P - St ol =0 e S S A BT o | e
| - 3 -
i [ e S e e e ] o | [
Fr——— =
= =1 alntbe ¥
F | - E
Tt Arewnsoon
_— o
! sty #
i O ()
Z = Frent Erpat
q " s [ atemisdy . ¥
- mﬂvig;lﬂm
i-'*.mr.mls .
! 0 - sk o 4
i"""'“' - Rt FURE [
Anoistons D - Seawine SatSein
| 1reradal 0~ Servios Bl W HTTFirgai gl
7 5 (1 - Snen Frrpesties
[y B g T DL 0. e B 6% Fratparacam |
[~ Fliglsiam e
0 - Soapaction
[~ Soagiiemn i 2
R £
5| !_LEJ
LT :
Wt | & o ) B || varemsndse, | o Promewises | G Py, || sean - Rerekbrg-For | (@ 192t

Configure also the final process’ step with the binding EndService->JBI-ConsoleOutputBindingComponent.
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The process is completed: the BPMN diagram was annotated with all the technological information needed to perform

deploy and monitoring.

To perform these activities you need to execute an intermediate step that consists of generating an Eclipse model (called

Intermediate Model) that allows in future using the Spagic features also with editors different from the BPMN editor.

Select the BPMN file (not the diagram, the file that ends with .bpmn) and after right click on it, choose BPMN For
Intermediate Model->Export BPMN To Intermediate Model.

EIL/:? IntegrationProcess ‘ ‘

Mew 3
Jpen F3 4’0
Cpen With r i
= SemanticRy efnd
1= SyntaxRule =) COPY Chrl+C
o[ WsdFiles | [ Paste Chrb
¥ Delete Delete
Mave. ..
Rename Fz
2 Impart...
&7 Expoart...
2 | Refresh F5
rVers EE outline | £ IntermediateModel £3
Validate P
riceMix
1] Mark as Landmark Ctrl+Ale+5hift+Up "
iz
2k Remove from Conbesxt CErH-AlE+-Shift+-Dowin
Initialize bpmn_diagram diagram file
Run &5 ¥ IhdingComponent
Debug As ¥ IngCompanent
Profile &s » |gComponent
Team » pCompanent
Compare With 4
Replace With 4
Source L4
BPMM Faor Intermediate Model 4 Iter Configuration

Wersion Bprn Diagram
firs Properties Ale+Enker AR T Tk

You should see a new file called firstProcess.im: this is the file necessary for deploy and publication on meta-db.

Every time you change the BPMN diagram, you must regenerate the Intermediate Model.

6.2.2 BPEL Technology
Modify the previous process with the following steps:
e Add a new step.

e Select, from the component palette located at the right of the editor, a Task element and put it to the editing

area; assign it the name “assign”.

e Link the start element with the task element and the task element with the end element.
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Select the pool firstProcess (it should be unique) and in the view Properties select the Tab Technology: here you should
found a combo containing the supported technologies.

Choose “BPEL Runtime” and select Bind to Runtime: now your process has the BPEL technology associated, and you
are ready to use the services provided by this specific technology.
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In the next steps you have to specify which specific technological services are bound to the steps of your BPMN
diagram.

Spagic Getting Started ver. 2.2, May 13, 2009 - pag. 16/ 32

Engineering Ingegneria Informatica S.p.A., 2007, 2008. This work is
@creatlve licensed under the Creative Commons Attribution-ShareAlike License. To
.~ view a copy of this license, visit http://creativecommons.org/licenses/by-
COMMONS D EED 83/30/




Spagic Getting Started

To do this, select the view IntermediateModel: you should see the list of all services available for BPEL.
Open the StartService category and drag the service BPEL-Receive on the step start.
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Spagic Studio asks if you want to associate this BPMN step with the BPEL service (also called Binding) BPEL-Receive
that is a receive activity.

| |

-i:{A\o — [
i Atkach Service[StartService] with Binding {BPEL-Receive) on on Empby Start Event stark
start : g end | - —
[=3t.., *

To display all the properties, select the start step, then the Properties tab, in the item IM-Model.
All properties have been configured.

Configure the assign step with the binding TaskService->BPEL —Assign.
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You have to configure the assign step: select it and configure all the properties in the Properties tab, in the item IM-

Model. Set the property assignmentType with value Variables, the property from(Variable) with value input, the property

to with value output.
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Configure also the final process’ step with the binding EndService->BPEL-Reply.
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The process is partially completed: the BPMN diagram was annotated with some technological information needed to

perform deploy and monitoring.

To perform these activities you need to execute an intermediate step that consists of generating an Eclipse model (called

Intermediate Model) that allows in future using the Spagic features also with editors different from the BPMN editor.

Select the BPMN file (not the diagram, the file that ends with .bpmn) and after right click on it, choose BPMN For
Intermediate Model->Export BPMN To Intermediate Model.
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You should see a new file called firstProcess.im: this is the file necessary for deploy and publication on meta-db.

Every time you change the BPMN diagram, you must regenerate the Intermediate Model.

6.2.2.1 Complete with further technical definitions

The BPEL process is partially completed: the BPMN diagram was annotated with all the technological information
needed to perform monitoring but we have to add further technical definitions. For this purpose, we preferred to use a

specific designer: BPEL Designer.

In the editor area, select the .im file, open the context menu and select Intermediate Model->Generate BPEL Model.
Into the folder Bpel, the new folder firstProcess was generated, containing the files firstProcess.bpel and

firstProcess.wsdl
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To complete the bpel process execute the following steps:

1.

T Chosragles dttrbanas =

Tee “lariabla b

Al e T
© @ ougrs : FindFrocesR aparoe Famage

Cumny: -

Select the Initialize Variable activity and then the tab Properties : specify the payload for the output variable;
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6.2.3 Workflow Technology

Once designed the process, you can generate the JPDL process description and publish it.
To generate the JPDL, select the BPMN file, right click on it and choose the “Spagic Workflow-> Generate Workflow
Definition (JPDL)” command.

L e WU . |

(1BPM/Int tionP
Replace With i “H-'II'I egrationPr:

Spagic Workflow Generate Workflow Definition { JOPL )

BPMM For Intermediate Model

-

-

You should find now the file <processName>.jpdl within the folder Deployables (also an intermediate file should be
generated within the folder IntegrationProcess and should be called <processName=>.im).

To publish the process, select the JPDL file and choose “Spagic Workflow->Deploy ( JBPM )’: the process now is
published on both JBPM and Spagic databases, and you should find it with the Monitoring Console.

Replace With L

A Spagic Workflow b Deploy { JBFM )
I [T T, PN PR Al

For a complete guide of the Spagic workflow please refer to the document “Spagic Workflow Getting Started”.

6.3 Publish the process

After designing the process, you have to publish it: this step will save the process information (properties, flow...) into the
MetaDB.

In the editor area, select the .im file, open the context menu and select Intermediate Model->Publish to MetaDB.
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C
c Cpen F3 )—’O
Cpen iiith L4
ot end
1l 3= Copy Chrl+C
= [ Paste ZEr| Y
3 Delete Delete
Move,. .
Renarme Fz
g Impart. ..
7 Export...
I—
2 | Refresh F5

4k Servers EE outling | = Intermed
Validate

ache ServiceMix

gﬂ Mark as Landmark Crrl4+-ale+5hift+Up e SarviceMix

22 Remove from Context Ctrl+alt+5hift+Down
Run As 4
Debug As P butputBindingCermponent
Profile As F |putBindingComponent
Team b |utBindingCamponent
Campare With » LtBindingComponent
Replace With 4
Source 4
Intermediate r| Publish to MetaDE

aenerate WaDL For Service Mix
Properties Alt+Enter

Generate Service Mix Application
“Process.im - StartSpagic/IntegrationProcess Generate BPEL Model

If you have some errors, verify that you installed graphviz tool and you created the temporary directory that should be

configured in the Spago Preferences, in the item Graphviz temp folder.

Spaic Sturio Preference Letault Urganizaton | Engineering |
Team Graphviz dot program Location | : fProgrammifATT fGraphviz binfdot |
Validation -
Graphviz temp folder C: ftm
Web and XML S s e
Web Services SMy GetResources Service Hocalhost: 9092 jgetResources)/
xDoclet
< = [Rest:ure Qefaults] [ Apply ]
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6.4 Deploy the process

To deploy the process implemented with JBI technology, in the editor area, open the context menu after selecting the
.im file and select Intermediate Model->Generate Service Mix Application. The firstprocess_v_0-sa.zip will be created in

the project Deployables folder.

SuurLe " hodified
Intermediate Model Publish to MetaDB
Generate WDL For Service Mix

Properties Alt+Enker

vice Mix Application
Generate BPEL Maodel

tProcess.im - Start3pagic/InteqgrationProcess

The label _v_0 is assigned to the process because it's now possible to specify the process version: you have not

specified this information, so the default version (0) is assigned.

To deploy the process implemented with BPEL technology, in the editor area, open the context menu after selecting the

.bpel file and select Deploy->Deploy in Service Mix.
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A pop-up window will be displayed, insert the process uri: http://localhost:8214/firstProcess and then click the Ok button.

The firstprocess-sa.zip will be created in the BPEL folder.
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W Spagic

Start ServiceMix launching the command bin\servicemix.bat (or

.sh) from apache-servicemix-{SERVICEMIX_VERSION}.

After ServiceMix was started, copy the .zip generated in the hotdeploy folder and verify in the ServiceMix console that

the process was deployed without errors.

INFQ - ComponentMBeanImpl — Starting component: transformerForSupplier
INFO — JBIContainer — Activating component for:
zservice: {http:/rservicemix.org/cheesezsupplierScreenfutput component:
lerComponentf 79885

— GomponentMBeanImpl
ComponentMBeanImpl
AutoDeploymentService
fiutoDeploymentService
ServicefssemblyLifeCycle
ServicellnitLifeCycle
ServicellnitLifeCycle
ServicelnitLifeCycle
Jetty
Jetty
ServicelUnitLifeCycle

Initializing component: supplierScreenQutput

Starting component: supplierScreenfutput

Directory: deplo Finished installation of archive: storedar.zip
Directory: deploy: Archive changed: processing transformerJar.zip ..
Starting service assembly: transformer

Initializing service unit: transformerhttp—szu

Initializing service unit: transformerlu—su

Starting service unit: transformerhttp—su

Jetty—6.8.1

Started SelectChannelConnector B localhogt 8194

Starting service unit: transformerl

— JBIGontainer fictivating component for: [containe
with service: {http:/rservicemix.orgrs/cheesedmylransfornertransformer component
ltComponent@2d465a
INFO — ComponentMBeanImpl
INFO — ComponentMBeanImpl
INFO — JBIContainer

with service:
StreamtriterComponentBl28hif?

— ComponentMBeanImpl
ComponentMBeanImpl
AutoDeploymentService
fAutoDeploymentService
ServicefAssemblyLifeCycle
ServicelnitLifeCycle
ServicelnitLifeCycle
ServicelnitLifeCycle
Jetty
Jetty
ServicelnitLifeCycle

— JBIContainer
with service:
reamlriterComponentPe?62ec
INF — ComponentMBeanImpl
INFO — ComponentMBeanImpl
INFO — AutoDeploymentService

org.apache.servicemix.componen

— Initializing component: myTransformertransformer
— Starting component: myTransformertransformer
— Activating component for:

— Initializing component:
Starting component:

myScreenfutputtransformer
myScreenOutputtransformer

Directory: deplo Finished installation of archive: transformerda
Directory: deplo fArchive changed: processing firstproce

Starting service assembhly: firstprocess

Initializing service unit: firstprocesshttp—su

Initializing serwice unit: firstprocessluw—su

Starting service unit: firstprocesshttp—su

Jetty—-6.8.1

Started SelectChannelConnector @ localhost:8195

Starting service unit: firstprocesslu—su

Activating component for: [contain

— Initiali=zing component:
— Starting component:
— Directowry: deploy: Finicshed installation of awchive:

ScreenQutputfirstprocess
ScreenQutputfirstprocess

firstprocessJar.zip

[container=ServiceMix.name=supplierS8creenfutput] wit
org.apache _servicemix.conponents .util._ Streambri

erulceHlX.name=myTransformertransfnrmer]
wslt . X

[container=8erviceMix.name=nyScreenfutputtransforner|
{http://servicemnix.org-scheesedmyScreenfutputtransformer component: org.apache.servicemix.components.util]

erviceMix.name=ScreenQutputfirstprocess]
{http://servicemix.orgscheese}Screenfutputfirstprocess component: org.apache.servicemix.components.util.$

7 Run the Process

To run the process you can use a simple HTML page that invokes, with an AJAX call, the Web Service defined in the

firstprocess process.

You can find this page in the distribution, in the package spagic-service-manager, within the folder “sample-clients”.

Use the page client.html to launch the JBI process or the page clientBpel.html to launch the BPEL process.

Open the HTML page with Mozilla and click the button sendSOAP to start a new process execution.
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» Spage

8 Monitor the Process

Spagic Console is a web application to monitor, through Ajax interface, the system information (system monitoring), the
services, and the processes (services monitoring).

It's recommended to use the Firefox Mozilla 3.x.

For more details about Spagic Console please read the document Spagic Studio User Guide.doc.

Start the Tomcat where you installed the Spagic Console.

8.1 Authentication

The URL to launch the Spagic Console is: http://localhost:8080/Spagic/.

The first page visualized by the web application is the authentication page.

Insert the user spagic and the password spagic and then click the button 128

) Sagic Caneele - Meaila Frelne =X
i pooifes  Suslens  Prondags  Sggnaltn an_:-n I

- ;‘- 5] et occat: 200 2 =l -

B o T »

Corphtatn

The next page contains the application menu.

W Spagic

o oom RE L oA
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» Spage

8.2 Process List

Select the icon Process List (lfl;llfl) to view all processes and theirs configuration, properties, and static flow diagram. The

list contains the following attributes:

Name: process name.

Type: process technology.
Valide From: start validity date.
Valide To: end validity date.

YV V V V V

Instance: number of process instances.

»  w:displays the process detail containing the description, version, organization, service name.

ﬁqﬂl: displays the process graph.

Y

The process list should contain only firstProcess: the process just deployed and launched.

T apngic Carreebs - Mgails Frelos alE] x|

:h_uuuuu-hnnm-wm:

& - - = ;‘- Iam:lwuu.mmupmmwuurr::m1|v.1|_.w-m-.-m|rmmnum wife =
| Spa Corerle
o <

misre vy Vo Frass Vidn Ts nistsdng o

You can perform a search by Taxonomy (if you choosed to install jUDDI or freebXML) or by /ter using the section in the

left side of the page.
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8.2.1 Process Graph

Selecting the icon at from the process list, it's possible to display the process graph.

Selecting the elements on the graph it's possible to display a window containing Name, step Description, Service and its
Properties.

Cpreiabs - Pacile Frelos =] x|
| K

Li-Spe v
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Hursa [reetFrocazrctart v

Pt |N|:rﬂm~h| tart
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o i
e
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8.3 Process Instances List

Selecting the icon Process Instances List (ﬂ'i) the process instances list is showed. The list contains:
» Id: identifier of process instance.

Process: process name.

Iter: name of the iter (optional) associated to the process instance.

Instance: attributes identifying the iter instance (optional).

Start: start execution time.

End: end execution time.

State: instance state. It can be active (yellow V), executed (green V) or fault (red X).

> a : visualizes the process execution detail.

T apngic Carreebs - Mgails Frelos alE x|
[ _uunu ‘Sumlers  [romckagie sn_nnm an_:-n T
e - - = "“- Iam:lwuu.mmwspmmwuurr::m1|-:\u_.-.|wm-mrr-mlulunm.m-r. wife =

Console: 8] Teat rstPrmoess

d - Pz nstesces Lind '.'.:; ':'2 H ial

al  Frecesy Mo irbancw Shart Tl Hluie

It's possible to perform a search by Taxonomy or by lter using the section in the left side of the page.
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8.3.1 Process Instance Graph

Selecting the at icon from the process instances list it's possible to display the graph representing the execution of the
process.

The color of the component represents the component state: the green color means executed, the yellow color means
active and the red means error.

Selecting the elements on the graph it's possible to visualize the window containing Detail and Relevant Data.

The Relevant Data tab contains the messages having as destination the component selected. Selecting the XML link in

the list, the XML message will be visualized; in this case Request and Acknowledge.
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» Spage

8.3.2 Advanced Search

Selecting the icon Advanced Search (=) in the Process Instances List, at the top of the page, the Advanced Search

page is displayed.

The page contains:

»  Process: process name.

vV V.V V V V V

Iter type

Version: process version.

Type: process technology.

From and To: start and end validity process dates.
State: it can be Executing, Error, Executed.

Order by: order criteria.

Thswagic Carrcebs - Mgafls Frelos
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Organization: process organization if the process was published on a service registry (jUUDI or freebXML).
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9 Related documents

The publications listed in this section are considered particularly suitable for a more detailed discussion of the topics

covered in this document.

1. Spagic JBI Components.doc: detail document about ServiceMix and Spagic JBI components.

2. Spagic Console.doc: detail document about Spagic Console monitoring application.
3. Spagic Studio User Guide.doc: detail document about Spagic Studio environment.
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