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Introduction

The Funambol Outlook Plug-in provides synchronization functionality for Microsoft Outlook. 
After installing the software, you can synchronize data in Outlook with that stored in 
enterprise data sources, including email, PIM data, and files. This document described how to 
install, configure, and use the software.

Prerequisites

The system requirements for using the Funambol Outlook Plug-in are as follows:

• Microsoft Outlook 2000 or 2003.

For information on obtaining Microsoft Outlook, see “Other Resources” on page 13.
1
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Instal lat ion

The section provides details for obtaining, installing and configuring the software.

Obtaining the Software

The Funambol Outlook Plug-in software is available as follows:

Download Site: www.funambol.com/opensource/downloads.html

File: funambol-outlook-plugin-3.0.x.exe

Size: 2.4 MB

The file contains the following:

• Funambol Outlook Plug-in version 3.0.x

• Outlook Redemption Library version 4.1. For details, see “Resources” on page 13.

Installing the Software

If a previous version of the plug-in is installed, you should uninstall that version before 
proceeding.

1. Run the executable installation file.

2. Review the license agreement. To accept the terms, select the checkbox and click Next.

3. Accept the suggested Destination Folder (i.e., the \Funambol\plug-ins\Funambol 
Outlook Plug-in directory) and click Next.

4. Accept the suggested Start Menu Folder (i.e., the \Funambol\Funambol Plug-
ins\Outlook Plug-in) and click Install.

5. Review the Outlook Redemption license agreement. To accept the terms, select the “I 
agree” radio button and click Ok.

6. Click Finish to close the setup wizard.
2
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Accessing the Outlook Plug-in in Microsoft Outlook

The installation process creates a ‘Funambol’ menu item on the Outlook main menu bar, with 
the following selections:

• Funambol > Synchronize – synchronize using the current settings.

• Funambol > Configuration – opens the plug-in as a separate application for configuration 
or other tasks.

The installation process also creates the Funambol icon (two circular arrows) on the Microsoft 
Outlook toolbar that performs the same action as the Funambol > Synchronize menu 
selection above.

NOTE:  The plug-in can be started as a separate application via the Windows Start button.

Configuring the Plug-in

To configure the software, perform the following: 

1. Start Microsoft Outlook and on the main menu bar select Funambol > Configuration. 
After the Outlook Plug-in standalone application opens, access the communication 
settings by selecting Edit > Communication Settings.

or

Start the Funambol Outlook Plug-in standalone application in Windows by selecting Start 
> All Programs > Funambol > Funambol Plug-Ins > Outlook Plug-in > Funambol 
Outlook Plug-in. Access the communication settings by selecting Edit > Communication 
Settings.

2. Specify the following settings: SyncServer URL, Username, and Password and click OK. 
For details, see “Communication Settings” on page 7.

3. Choose the sources with which to synchronize, and set the appropriate parameters for 
each. For details, see “Synchronization Settings” on page 9. Note that default parameters 
are set on the Funambol server for synchronizing contacts and calendar.

Uninstalling the Software

To uninstall the software, perform the following: Start > All Programs > Funambol > 
Funambol Plug-Ins > Outlook Plug-in > Uninstall.
3
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Using the Funambol Outlook Plug-in

This section introduces the features of the Funambol Outlook Plug-in.

Home Screen

When you start the Outlook Plug-in, the following screen appears:

This screen provides the following functionality:

• Main menu – access menus for synchronizing, specifying configuration settings, viewing 
a log file, and quitting the plug-in.

• Synchronize button – click to synchronize data using the current settings.
4
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Main Menu Overview

The Funambol Outlook Plug-in main menu contains the following selections:

The selections perform the following actions:

Selection Action

File > Synchronize Synchronizes data using the current settings. This is 
the same as clicking the Synchronize button.

File > Recover (slow-sync. . .) Displays a window for choosing a source with which 
to perform a slow-synchronization.

File > Exit Exits the plug-in.

Edit > Communication Settings Displays a window for specifying communication 
settings.

Edit > Synchronization Settings Displays a window for specifying synchronization 
settings.

Edit > Scheduler Settings Displays a window for specifying scheduler settings.

Help > View log Displays the contents of the log file.

Help > About Displays the version number the plug-in.
5
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File Menu

The File > Synchronize and File > Exit selections perform direct actions, i.e., synchronize 
using the current settings and quit the plug-in. The File > Recover (slow-sync)... selection 
displays the following window:

Choose the source with which to synchronize by checking the appropriate checkbox. Click 
Synchronize to start a slow-sync; click Cancel to close the window without synchronizing.
6
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Edit Menu

You use the Edit menu to access the following settings:

• Communication Settings – the communication parameters between the Funambol Data 
Synchronization server and the plug-in.

• Synchronization Settings – the source to be synchronized, and preferences associated 
with synchronization with that source.

• Scheduler Settings – a time interval at which synchronization will automatically occur 
without user action.

Communication Settings

You access communication settings by selecting Edit > Communication Settings. The 
following window displays:

Click OK to save the settings; click Cancel to close the window without changes.

Setting Description

SyncServer URL The URL of the synchronization server.

Username The user ID used to access the database associated with the 
synchronization server.

Password The password used to access the database associated with the 
synchronization server.

Proxy Settings See “Proxy Settings” on page 8.
7
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Proxy Settings

You access these settings by selecting Edit > Communication Settings and then clicking the 
Proxy Settings button, as shown below:

If using a proxy that requires authentication, these settings are useful to avoid the repeated 
display of the proxy parameters window (for scheduled synchronizations). Click OK to save 
the settings, click Cancel to close the window without changes.

Setting Description

Save Proxy Username / 
Password

Enables the proxy settings. If a proxy authorization is required 
and this checkbox is enabled, the plug-in will automatically 
connect through the proxy using the values specified for 
Username and Password. Otherwise, a window will display 
during synchronization process, prompting the user to specify 
the Username and Password.
If no proxy connection is detected, these settings are ignored. If 
a proxy connection is detected but no authorization is 
required, these settings are ignored (the internet settings 
defined in the Windows control panel will be used).

Username The username used to communicate through the proxy.

Password The password used to communicate through the proxy.
8
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Synchronization Settings

You access synchronization settings by selecting Edit > Synchronization Settings. The 
following window displays:

Setting Description

Select the source with 
which to synchronize:
• Contacts

• Calendar

• Tasks

• Notes

For the selected source, specify the type of synchronization. 
The valid selections are as follows:
• Normal – two-way fast synchronization.

• Replace Local Data – replaces the data on the client with the 
data from the server.

• Replace Remote Data – replaces the data on the server with 
the data on the client.

• Update Local Data – updates the data on the client with the 
data from the server.

• Update Remote Data – updates the data on the server with 
the data on the client.

Encryption Enables content encryption using the 3DES algorithm (global 
parameter).

Remote Settings See “Remote Settings” on page 10.
9
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Click OK to save the settings; click Cancel to close the window without changes.

Remote Settings

You access these settings by selecting Edit > Synchronization Settings and then clicking the 
Remote Settings button, as shown below:

Log level Specifies the type of data stored in the log file. Select one of the 
following:
• None – No data stored in the log file.

• Info – Informational data stored in the log file.

• Debug – Debug data stored in the log file.

When set to Info or Debug, the file contains the log only for the 
last synchronization. 

Setting Description

Setting Description

Contact Name String that represents the contacts synchronization source (i.e., 
the URI) on the server. The following strings are valid:
• scard – SIF

• card – v-Card (checkbox must be selected)
10
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Click OK to save the settings, which are stored in the device registry and used in subsequent 
synchronizations. Click Cancel to close the window without changes.

Scheduler Settings

You access scheduler settings by selecting Edit > Scheduler Settings. The following window 
displays:

These settings specify a time interval at which synchronization will automatically occur 
without user action. To set a time interval, perform the following:

1. Select the Activate checkbox.

2. Specify the number of time units (i.e., number of minutes or number of hours).

3. Specify the time unit (i.e, minutes or hours).

Click OK to save the settings, Cancel to close the window without changes, or View log to 
view the log file.

Calendar Name String that represents the calendar synchronization source (i.e., 
the URI) on the server. The following strings are valid:
• scal – SIF

• cal – i-Calendar (checkbox must be selected)

Task Name String that represents the tasks synchronization source (i.e., 
the URI) on the server. The following string is valid:
• stask – SIF

Note Name String that represents the notes synchronization source (i.e., 
the URI) on the server. The following string is valid:
• snote – SIF

Setting Description
11
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Help Menu

You use the Help menu to access the following:

• View log – displays the log file.

• About – displays information about the software.

View log

You access the log file by selecting Help > View log, as shown below:

This selection opens the log file in Notepad.

About

You access information about the software by selecting Help > About, as shown below:
12
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Resources

This section lists resources you may find useful.

Related Documentation

This section lists documentation resources you may find useful.

Funambol DS Server Documentation

The following documents form the Funambol DS Server documentation set:

• Funambol DS Server Architectural Overview: Read this document for an overview of the 
architecture.

• Funambol DS Server Administration Guide: Read this guide to gain an understanding of 
installation, configuration, and administration.

• Funambol DS Server Developer’s Guide: Read this guide to understand how to develop 
extensions to the server.

• Funambol DS Server SyncSource API: Read this reference guide for information on the 
SyncSource interface and related classes.

• Funambol DS Server Quick Start Guide: Read this guide to install and run a simple 
demonstration of synchronizing PIM data using the Funambol DS Server.

• Funambol DS Server Module Development Tutorial: Read this tutorial for instructions on 
packaging, installing and testing modules.

Other Resources

This section lists other resources you may find useful.

• For information on Microsoft Windows Outlook, visit http://www.microsoft.com/office/
outlook/prodinfo/default.mspx.

• For information on Outlook Redemption, visit http://www.dimastr.com/redemption.
13
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